Symfony/dependency-injection v3.3.0 conflicts with symfony/console[v4.1.8]


(Geert DL) #1

Beste Magento teamleden,

14 dagen geleden heb ik magento 2.2.6 geïnstalleerd. Veel staat er nog niet op. Enkel een betaalmodule van sisow, categorie uitbreiding, cookie tool en nl taalbestand. Nu is Magento 2.3 er en ik dacht, even snel updaten naar 2.3 via “system upgrade”. Echter bij readyness Check loop is vast. Ik heb al verchillende versies van dependency-injection geprobeerd. nu is het versie dependency-injection v3.3.0. Als ik nog lager ga gaat het helemaal mis. Bij hogere versies krijg ik nog meer conficten.

help!

Check Component Dependency

We found conflicting component dependencies. Hide detail

Command “update” failed: Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1

  • Installation request for magento/product-community-edition 2.3.0 -> satisfiable by magento/product-community-edition[2.3.0].
  • magento/framework 102.0.0 requires symfony/console ~4.1.0 -> satisfiable by symfony/console[v4.1.0, v4.1.1, v4.1.2, v4.1.3, v4.1.4, v4.1.5, v4.1.6, v4.1.7, v4.1.8].
  • symfony/dependency-injection v3.3.0 conflicts with symfony/console[v4.1.0].
  • symfony/dependency-injection v3.3.0 conflicts with symfony/console[v4.1.1].
  • symfony/dependency-injection v3.3.0 conflicts with symfony/console[v4.1.2].
  • symfony/dependency-injection v3.3.0 conflicts with symfony/console[v4.1.3].
  • symfony/dependency-injection v3.3.0 conflicts with symfony/console[v4.1.4].
  • symfony/dependency-injection v3.3.0 conflicts with symfony/console[v4.1.5].
  • symfony/dependency-injection v3.3.0 conflicts with symfony/console[v4.1.6].
  • symfony/dependency-injection v3.3.0 conflicts with symfony/console[v4.1.7].
  • symfony/dependency-injection v3.3.0 conflicts with symfony/console[v4.1.8].
  • magento/product-community-edition 2.3.0 requires magento/framework 102.0.0 -> satisfiable by magento/framework[102.0.0].
  • Installation request for symfony/dependency-injection 3.3.0 -> satisfiable by symfony/dependency-injection[v3.3.0].