Upgraden via SSH


(Roland Reijerse) #1

Ik probeer te upgraden via SSH, ik vraag via

php bin/magento --version

Het huidige versie nummer op (2.1.6 is dat nu) en wil upgraden met

composer update

maar krijg hier een foutmelding op die ik nergens zo 123 kan oplossen, zijn er mensen die dit al eens zijn tegen gekomen ?

de foutmelding is…

Your requirements could not be resolved to an installable set of packages.


(Wiard Van Rij) #2

Kan je ook je composer.json posten? Dat zal namelijk een hoop verklaren


(Wiard Van Rij) #4

Het eerste deel zou je dan op:

"name": "magento/project-community-edition",
"description": "eCommerce Platform for Growth (Community Edition)",
"type": "project",
"version": "2.2.0",

kunnen zetten.

En dan de require veranderen;

“magento/product-community-edition”: “2.2.0”,

en composer/composer mag ook naar

“composer/composer”: “1.4.1”,

In feite staan in de composer.json de versies die je wilt installeren. Tenzij je een wildcard hebt zoals
"magento/product-community-edition": “*” zal hij met een update niets gaan updaten omdat er niets te updaten valt omdat je specifiek een versie specificeert.

Pretty sure dat dit je probleem is waarom je verder niets kan…


(Wiard Van Rij) #6

Ja de melding staat er eigenlijk al.
Je required base 2.1.6 maar die required weer composer <= 1.0.0-beta1

Kijk even naar de composer van de official repo:

Dus of zet composer weer op
“composer/composer”: “@alpha”,

of kijk even waarom je
“magento/magento2-base”: “2.1.6” required
Immers is ook 2.2 uit: magento/magento2-base : 2.2.0 - Magento 2 Base (Community Edition) en die required 1.4.1 van composer/composer oftewel die zou wel werken.

Het is ook handig om even een beetje te verdiepen in composer & packages. Als je de basics snapt kun je vrijwel elk issue wel oplossen.


(Roland Reijerse) #8

ps nu magento base naar 2.2.0 gezet ipv 2.1.6, eens zien wat hij nu doet…


(Roland Reijerse) #9

ondertussen al weer wat aangepast…
{
“name”: “magento/project-community-edition”,
“description”: “eCommerce Platform for Growth (Community Edition)”,
“type”: “project”,
“version”: “2.2.0”,
“license”: [
“OSL-3.0”,
“AFL-3.0”
],
“require”: {
“magento/product-community-edition”: “2.2.0”,
“composer/composer”: “@alpha”,
“hellobrave/cookiecompliance”: “1.0.4”,
“vsourz/order-success”: “1.0.0”,
“honl/magento2-nl-nl”: “1.1.1”,
“vsourz/ordercomment”: “1.0.0”,
“fooman/printorderpdf-m2”: “^2.1”,
“fooman/emailattachments-m2”: “^2.0”,
“weltpixel/m2-weltpixel-backend”: “1.0.3”,
“weltpixel/m2-weltpixel-owl-carousel-slider”: “1.3.1”,
“magento/module-swatches”: “100.2.0”,
“magento/magento2-base”: “2.2.0”
},


(Roland Reijerse) #12

Nou 600 fouter verwijderd uit de backup (want ja die moest terug gezet worden) zijn we weer bezig met composer update…

met deze composer.json aan het stoeien nu…

{
“name”: “magento/magento2ce”,
“description”: “Magento 2 (Community Edition)”,
“type”: “project”,
“version”: “2.2.0”,
“license”: [
“OSL-3.0”,
“AFL-3.0”
],
“require”: {
“magento/product-community-edition”: “2.2.0”,
“composer/composer”: “@alpha”,
“hellobrave/cookiecompliance”: “1.0.4”,
“vsourz/order-success”: “1.0.2”,
“honl/magento2-nl-nl”: “1.1.1”,
“vsourz/ordercomment”: “1.0.0”,
“fooman/printorderpdf-m2”: “^2.1”,
“fooman/emailattachments-m2”: “^2.0”,
“weltpixel/m2-weltpixel-backend”: “1.0.3”,
“weltpixel/m2-weltpixel-owl-carousel-slider”: “1.3.1”,
“magento/module-swatches”: “100.1.5”,
“magento/magento2-base”: “2.1.6”
},
“require-dev”: {
“phpunit/phpunit”: “4.1.0”,
“squizlabs/php_codesniffer”: “1.5.3”,
“phpmd/phpmd”: “@stable”,
“pdepend/pdepend”: “2.2.2”,
“lusitanian/oauth”: “~0.3 <=0.7.0”,
“sebastian/phpcpd”: “2.0.0”
},
“config”: {
“use-include-path”: true
},
“autoload”: {
“psr-4”: {
“Magento\Framework\”: “lib/internal/Magento/Framework/”,
“Magento\Setup\”: “setup/src/Magento/Setup/”,
“Magento\”: “app/code/Magento/”
},
“psr-0”: {
"": “app/code/”
},
“files”: [
“app/etc/NonComposerComponentRegistration.php”
]
},
“autoload-dev”: {
“psr-4”: {
“Magento\Sniffs\”: “dev/tests/static/framework/Magento/Sniffs/”,
“Magento\Tools\”: “dev/tools/Magento/Tools/”,
“Magento\Tools\Sanity\”: “dev/build/publication/sanity/Magento/Tools/Sanity/”,
“Magento\TestFramework\Inspection\”: “dev/tests/static/framework/Magento/TestFramework/Inspection/”,
“Magento\TestFramework\Utility\”: “dev/tests/static/framework/Magento/TestFramework/Utility/”
}
},
“minimum-stability”: “alpha”,
“prefer-stable”: true,
“repositories”: {
“0”: {
“type”: “composer”,
“url”: “####”
},
“foomanartifacts”: {
“type”: “artifact”,
“url”: “/home/u16572p12132/public_html/vendor/fooman/packages”
}
},
“extra”: {
“magento-force”: “override”
}
}


(Roland Reijerse) #13

Yes, we boeken vooruitgang, ik heb 2.2.0 opgegeven en dacht laat ik eens 2.1.9 proberen. Dat werkte prima dus hij draait nu in iedergeval al op een versie of 3 hoger!

nu nog zien dat we hem op 2.2 krijgen en testen wat er evt. veranderd is…


(Roland Reijerse) #14

Helaas iets te vroeg gejuicht… wederom terug bij 2.1.6…

denk dat ik het maar eens aanbied om te laten doen… checkout weg en betaal opties ook weg in de admin…


(Roland Reijerse) #15

ik ben weer op 2.1.9, als ik verder wil updaten krijg ik diverse foutmeldingen, ook va de admin updaten lukt niet van modules, krijg deze melding… terwijl ip op php 7.0 draai…

Erg jammer, mis mijn chekout pagina nu ook :frowning:


(Roland Reijerse) #16

nou het is gelukt, uitbesteed en als antwoord terug…

dit was geen standaard update…